wpa_supplicant fails and reports weird AP address in association

Sergio Callegari scallegari
Mon Dec 18 08:00:25 PST 2006

> On Tue, Dec 12, 2006 at 12:15:44PM +0100, Sergio Callegari wrote:
> > I am trying to set up a wireless network including an Hamlet access
> > point and a Linux laptop with an intel 3945 wireless interface.
> I'm not familiar with "Hamlet access point". What is it? Is there a more
> specific model number and software version etc. available?
I don't have it at hand, but I'll let everybody have the exact model asap.
> > 1) my AP MAC address should be AA:BB:CC:DD:EE:30 as reported on the AP
> > web interface (only last byte is properly quoted here).
> >
> > 2) iwlist eth1 scan reports AA:BB:CC:DD:EE:33... i.e. the last byte is
> > different in 3 bits.
> It sounds like the AP is using more than one address. The oen shown in
> the web UI is likely the one from the wired interface, not wireless, in
> this case..
> > 4) when wpa_supplicant reports association, it says it is associating
> > with AA:BB:CC:DD:EE:33...
> >
> > 5) however, the subsequent debug of the 4 way
> > handshake shows AA:BB:CC:DD:EE:30 as the AP address...
> >
> > May this has anything to do with the failed handshake?
> Yes, very possible.
> > wpa_supplicant is version 0.5.4
> Could you please run with the latest wpa_supplicant version (0.5.6) and
> if that is also failing, please post a detailed debug log from
> wpa_supplicant (-dd on command line).
I'll see if I can try that... (btw, does anybody know if there are debs 
of wpa_supplicant 0.5.6 for ubuntu 6.10)?
In the meantime, just some little news....

I have had the occasion to try wpa_supplicant on the very same host but 
another AP (a linksys this time).  With the latter, everything is 
perfectly fine, both with WPA-PSK and WPA2-PSK.  So it appears to be a 
problem specific to the Hamlet AP. I have tried to look for hamlet 
firmware update, but I am running the latest.

BTW the WPA configuration on the linksys and the hamlet AP follow very 
different routes:
on the linksys I chose /either/ no security /or/ wep /or/ wpa. In other 
terms, WEP and WPA appear as alternatives. On the Hamlet box I have a 
two step setup.  First I chose whether to have basic cryptography or not 
(and this can be "open", "shared" or "both", with the possibility of 
setting a WEP key)... then on another setup stage I chose whether to 
have WPA-PSK or not, with the possibility of introducing a WPA-PSK key.  
So WEP and WPA appear as complementary.

So far I have tryed any possible option for the first basic 
cryptographic setup (I have actually tried all of them).  But is there a 
"proper" basic (wep?) cryptographic setup to be used with WPA?  This is 
very confusing and the Hamlet manual does not help.


More information about the Hostap mailing list