ioctl[SIOCSIWPMKSA]: No such device

Gustavo Michels gustavo.michels
Fri Jun 17 08:54:28 PDT 2005

Hi all

I've been using wpa_supplicant-0.3.8 for a while using WPA-PSK without a 
problem. I am now trying to use WPA2 since my wireless router does a better 
job with that.

Tried wpa_supplicant-0.3.8 with WPA2 but it would always simply time out. So 
I decided to try the latest development version, 0.4.2. Now I get the 
following error when starting wpa_supplicant, no matter if I use WEP, WPA 
or WPA2:

# wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -dd
ioctl[SIOCSIWPMKSA]: No such device

Searching the list archives, I found a reference thread [1], where it 
mentioned WE-18. As I am running kernel 2.6.11-ck10, it still was in WE-17, 
so I patched it to WE-18 and recompiled everything. However, I still get 
the same error.

I really don't know if the problem is within wpa_supplicant, ndiswrapper, or 
even the windows driver (does it have to support WPA2?), so I am asking you 
guys for any help.

If it helps, I am using ndiswrapper-1.1 with a Broadcom BCM4306, using the 
drivers provided by HP for my laptop (Pavilion ze4430us).



More information about the Hostap mailing list