wpa_supplicant problems

Rob Vandermeulen rob.vandermeulen
Tue Jul 12 01:58:30 PDT 2005

I finally got the sniffer working, so here are the logs from an xp client 
connecting (sniffer + ap logs) and the log from wpa_supplicant trying to 
connect (sniffer + ap + wpa_supplicant log). As the compressed package is 
79kb i probably can't attach it, so it's downloadable on 
http://www.redsoft.be/logs.tar.bz2 . Sniffing was done with ethereal.

The driver combination on the linux machine was ipw2200 1.0.4 and 
wpa_supplicant 0.4.3

Kind regards
Rob Vandermeulen

On Tuesday 05 July 2005 17:56, Jouni Malinen wrote:
> On Tue, Jul 05, 2005 at 02:08:54PM +0200, Rob Vandermeulen wrote:
> > Thanks for the information. I tried again, with PROT=WPA (akthough the AP
> > system should also support WPA2 and i did set an anonymous_identity).
> > Still no luck, and new logs attached.  I will try to setup a sniffer to
> > give you guys sniffer logs in  the next few days.
> This time the negotiation seems to go further, i.e., PEAP is actually
> started. However, the AP does nots eem to be processing the second EAPOL
> packet from the client for some reason. The debug log from the AP did
> not show it being received at all. In addition, the AP debug log seemed
> to talk about 60 second retransmission timer, but in practice, it is
> retransmitting the frame in 0.01 seconds.. If that is indeed what is
> happening, I would claim the AP is doing something odd. Anyway, getting
> a sniffer log of this could be enough to figure out what is happening
> here.

More information about the Hostap mailing list