can't get WPA-PSK working with ipw2100 against linksys WRT54G

Mike Campbell mlcampbell
Wed Jul 6 06:21:05 PDT 2005

On 7/5/2005 5:12 PM, Lubomir Gelo wrote:
>>>>>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> Error message says that IOCTL used by wpa_supplicant to communicate with
> the driver isn't supported by the driver. Please recompile the driver
> with the CONFIG_IEEE80211_WPA defined. 
> Also, as the data structure passed from wpa_supplicant to ipw* driver
> has changed in the latest unstable wpa_supplicant you have to use patch
> mentioned in this thread.
> LG
I checked the Makefile and it already has CONFIG_IEEE80211_WPA defined. 
I can see also that the objects ccmp.o and tkip.o are built and that 
only happens if WPA is enabled in the Makefile.

One thing that does look odd is that the Makefile defines 
CONFIG_IPW2100=m for some reason. I would expect that to be 
CONFIG_IPW2100=y. Is the 'm' correct or not?

I also tried the patch you reference with no luck. I tried 
wpa_supplicant 0.38, 0.39, and 0.43 (both with and without the patch) 
but all return the same thing.

My guess is that the ipw driver is not properly setting the wpa_ie or 
rsn_ie values. Is there a way to check these values outside of 

More information about the Hostap mailing list