can't get WPA-PSK working with ipw2100 against linksys WRT54G

Mike Campbell mlcampbell
Tue Jul 5 10:06:18 PDT 2005

On 7/5/2005 10:42 AM, Jouni Malinen wrote:
> On Tue, Jul 05, 2005 at 10:30:53AM -0500, Mike Campbell wrote:
>>I've tried about all I can think of and still can't get a WPA
>>connection to work on my Fedora FC4 box. I can get WEP working just
>>fine using the ipw2100 drivers but WPA always fails with the same
>>error. I have tried version 3.9 and 4.3 but no difference in the
> Which version of the ipw2100 driver are you using? You might also
> consider testing wpa_supplicant v0.3.8 since ipw driver interface was
> changed and the ipw2100/2200 drivers may not be fully in sync with the
> driver interface. wpa_supplicant 0.3.9 changes this interface to a newer
> one, so if your driver is still using the old version, 0.3.8 may work
> better.
>>When I run wpa_supplicant I see 2 possible problem areas:
>>I see the below message repeated 5-6 times each with a different
>>key_idx value but always the operation not supported and failed to set
>>wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
>>ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
>>Failed to set encryption.
> This is likely to be fine; wpa_supplicant just tries to make sure old
> keys are removed and the driver may report that it fails to remove keys
> that were not configured in the first place.
>>Then later on when it scans the AP's it is not able to find a suitable
>>one as I get:
>>Received 781 bytes of scan results (4 BSSes)
>>Scan results: 4
>>Selecting BSS from priority group 5
>>0: 00:13:10:32:af:21 ssid='MCAMPBELL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>>   skip - no WPA/RSN IE
>>For some reason the wpa_ie_len and rsn_ie_len is 0 for all found AP.
> This is more serious issue. It looks like the driver does not report
> that the AP is using WPA. Unless you are already using the latest
> version of the driver, I would recommend updating it first.

Sorry about replying in html format earlier. I've resent my previous 
update in text only mode:

I already had the latest ipw2100 files - driver is 1.1.0 and the
firmware is 0.55. I took your suggestion and went and downloaded and
compile the wpa_supplicant 0.38 and still have the same problem. No
difference in the output.

The odd part is that all detected AP's have the 0 length for the wpa_ie
and rsn_ie. What do these values mean? What would be expected here?


More information about the Hostap mailing list