can't get WPA-PSK working with ipw2100 against linksys WRT54G

Mike Campbell mlcampbell
Tue Jul 5 08:30:53 PDT 2005

I've tried about all I can think of and still can't get a WPA
connection to work on my Fedora FC4 box. I can get WEP working just
fine using the ipw2100 drivers but WPA always fails with the same
error. I have tried version 3.9 and 4.3 but no difference in the

When I run wpa_supplicant I see 2 possible problem areas:

I see the below message repeated 5-6 times each with a different
key_idx value but always the operation not supported and failed to set

wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.

Then later on when it scans the AP's it is not able to find a suitable
one as I get:

Received 781 bytes of scan results (4 BSSes)
Scan results: 4
Selecting BSS from priority group 5
0: 00:13:10:32:af:21 ssid='MCAMPBELL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
1: 00:11:50:53:8d:08 ssid='Patrick' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
2: 00:06:25:b5:c9:25 ssid='Hunter' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
3: 00:06:25:ba:63:5f ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE

For some reason the wpa_ie_len and rsn_ie_len is 0 for all found AP.
Any ideas why?

Here is my wpa_supplicant.conf file:
    psk="very secret"

Note that if I boot up into XP I am then able to use WPA just fine so
I know that the card is working.

More information about the Hostap mailing list