wpa_supplicant problems

Rob Vandermeulen rob.vandermeulen
Tue Jul 5 05:08:54 PDT 2005

Thanks for the information. I tried again, with PROT=WPA (akthough the AP 
system should also support WPA2 and i did set an anonymous_identity).
Still no luck, and new logs attached.  I will try to setup a sniffer to give 
you guys sniffer logs in  the next few days.

Kind regards

On Tuesday 05 July 2005 11:37, Jouni Malinen wrote:
> On Tue, Jul 05, 2005 at 10:57:30AM +0200, Rob Vandermeulen wrote:
> > My attempt at analyzing this data - something goes wrong pretty early,
> > the linux client never gets the AP to do a radius request. The SSL errors
> > in the WPA-supplicant log are probably an indication. EAPOL errors also
> > appear here and there. There is also a difference between the WinXP intel
> > associate and the Linux intel associate ... the first says "associated
> > RSN id" and the latter says "associated WPA id".
> That seemed to be the other way around, i.e., WinXP using WPA whereas
> wpa_supplicant was using RSN (=WPA2). However, the main difference
> seemed to be in identity configuration. The WinXP client was configured
> to use anonymous at myabc.com as the pase 1 identity and wpa_supplicant was
> configured to use testuser (i.e., the phase 2 identity). I would suggest
> trying setting anonymous_identity in wpa_supplicant configuration to
> anonymous at myabc.com, if the AP is expecting this. You can also force
> wpa_supplicant to use WPA by adding proto=WPA in the network
> configuration block.
> If the above mentioned changes are not enough to make the connection
> work, it would be useful to get a wireless sniffer log of the connection
> attempts from both WinXP and Linux clients.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wpa-logs2.gz
Type: application/x-gzip
Size: 4345 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20050705/91a1c43b/attachment.bin 

More information about the Hostap mailing list