hostapd groupkey problem with madwifi

Whoopie whoopie79
Fri Jan 14 09:10:36 PST 2005

I also deleted the line you mentioned. And now the authentication works. But 
because of unknown circumstances the connection breaks down.
auth_algs is set to 1.

Is your connection stable?


----- Original Message ----- 
From: "Sebastian Weitzel" <togg at>
To: "Whoopie" <whoopie79 at>
Cc: <hostap at>
Sent: Friday, January 14, 2005 5:59 PM
Subject: Re: hostapd groupkey problem with madwifi

>> Could you perhaps give another advice how to fix it.
> Hi,
> I read your mail from December. I have the exact same message in hostap
> log when I tried. After I removed the line I mentioned hostap worked with
> wpa_supplicant. Did you tried patching driver_madwifi.c?
> Looking at your log your client never really establishes an authenticated
> connection to hostapd. Speed falling back to 1mbit is normal in
> unauthorized state. Regarding your configuration, I think auth_algs should
> be 1 (open system) for security reason.
> Regards,
> Sebastian Weitzel

More information about the Hostap mailing list