hostapd groupkey problem with madwifi

Whoopie whoopie79
Fri Jan 14 07:31:06 PST 2005

since I?m searching for a solution for the EAPOL-Key timeout, your advice 
was very helpful.
But the connection crashes after about 10 seconds and doesn?t come back. The 
connection speed falls down to1 Mbit/s. Could you perhaps give another 
advice how to fix it.

Kind Regards,

----- Original Message ----- 
From: "Sebastian Weitzel" <togg at>
To: <hostap at>
Sent: Friday, January 14, 2005 1:44 PM
Subject: hostapd groupkey problem with madwifi

> Hi,
> I'm not sure if I should better ask this on the madwifi mailinglist, but
> since my problem occured through a change in hostap cvs I decided so.
> I was using hostapd successfully with madwifi till version 0.2.4 of
> hostap. I tried a fresh cvs checkout this year and it did not worked
> anymore.
> The connection is configured as WPA-PSK. Authentication process is not
> going further 1/4 of 4-way handshake.
> I tracked down the problem to a change in driver_madwifi.c, done on
> 18.12.2004, revision 1.6 of this file. If I remove the line "wk.ik_flags
> |= IEEE80211_KEY_DEFAULT;" it works again. By the way, hostapd prints outs
> eap timeout during authentication.
> The system I tested this issue on is a xscale ixp425 system, I dont know
> if the problem has anything to do with this.
> Regards,
> Sebastian Weitzel
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the Hostap mailing list