wpa_supplicant associates but dhcpcd cannot get IP address

Craig L gangis
Sun Feb 6 11:43:21 PST 2005


Apparently changing ap_scan to 1 and not letting it daemonize worked.
I shut it off, added the -Bw switch to let it daemonize and I'm still
experiencing the same issue. I then removed -Bw and tried again. It
apparently worked. From what I'm seeing, it only works if
wpa_supplicant doesn't run as a daemon. Any ideas? Thank you very

On Sun, 6 Feb 2005 11:29:22 -0800, Jouni Malinen <jkmaline at cc.hut.fi> wrote:
> On Sun, Feb 06, 2005 at 07:12:03PM +0000, Craig L wrote:
> > Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 'default'
> > Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
> > Reading configuration file '/etc/wpa_supplicant.conf'
> > eapol_version=1
> > ap_scan=2
> Please re-test with ap_scan=1 (the default value). I don't think madwifi
> driver or driver interface in wpa_supplicant work with ap_scan=2. If
> this does not work, please run wpa_supplicant manually with debugging
> enabled (-dd) and without daemonizing it so that you can get full debug
> log.
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list