Senao 2511CD+EXT2 and Ricoh PCI->PCMCIA interrupt delivery problem

Jerry mrcool
Mon Mar 15 16:10:49 PST 2004

Gawd, those ricoh bridges can be a pain...  ;)

One or the other of the following usually works for me.. although both
REQUIRE 'pci=biosirq' in lilo or grub (or syslinux).

1.  use: yenta socket  (kernel pcmcia) with 'pci=biosirq'
2.  use: i82365 (external pcmcia) with 'pci=biosirq' and the following (from
Ricoh's website):
"irq_mode=0 pci_csc=0 poll_interval=100"  for the pcic opts.

also, sometimes the stock kernel wont work (locks at boot like you
mentioned).  I had this problem in Wisp-Dist, and after compiling a custom
kernel, it now works... worth a try...

Good luck, also, might try and turn off acpi  ('acpi=off'  i think) at


> Hi !
> I have two cards Senao 2511CD+EXT2 and tho CardBus bridges Ricoh
PCI->PCMCIA . So i've installed the in two computers 1. Pentium 200, 2.
Pentium II 266 ( Both with AMIBIOS 1992 ).  So both cards don't work.
> Host AP gives a message that there is an interrupt delivery problem. I've
tried to fix it, setting in /etc/rc.d/rc.pcmcia  irq_mode=0,
pci_irq_list=5,9... ( pcmcia module is i83... not yenta, irqs can't be found
by Linux auto, and i can't give as a boot option pci=biosirq, systems hang
at boot time ). I've tried to change the memory and port in
/etc/pcmcia/config.opts - nothing.
> These cards worked fine with linux-wlan package, but i need host ap. I've
tried hostap - 0.0.3 and hostap - 0.1.3 , the both give same error messages.
pcmcia-cs package is version 3.2.7. Kernel is 2.4.24.
> I took the same card, with the same bridge and set it on Celeron 333A,
with PCCHIPS motherboard, with the same hard drive, and the card started
working just fine.
> Is there something else i can do ?
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the Hostap mailing list