dwl520e problem using hostap_fw_load

jeff pickering jpickering
Wed Mar 10 12:30:11 PST 2004

I thought maybe I required the kernel-patches, depsite the fact they are 
not described
in hostap-driver/README. So I upgraded to 2.4.24 which has a patches 
file and
enabled hostap in linux make xconfig. Now I when I do modprobe 
hostap_pci, I get:

hostap_pci.o: init_module: No such device

Which leads me to ask:

1) Do I need the kernel patches? If so, what needs to be set in make 
2) After restart, what if anything, needs to be done before modprobe 


Pavel Roskin wrote:

>On Wed, 10 Mar 2004, jeff pickering wrote:
>>Using hostap2.0 on linux2.4.22, I run into problems downloading firmware
>>to a dwl520e. Following andrew barr's web page I tried manually doing
>>the multiple prism2_srecs and following something on last month's
>>archives, I tried hostap_fw_load. Both result in failed ioctl()s.
>Maybe the primary firmware fails after the first load.  This problem was
>reported for both DWL-520e and DWL-650p.  Run the hostap_fw_load script by
>"sh -x" to see what was the last command.  Also see kernel messages.

More information about the Hostap mailing list