Performance drop in Bridge mode without WEP

Michael Guntsche mike
Sat Jun 26 10:59:01 PDT 2004


Looking at the WPA issues I have with my setup here, I saw a very 
strange behaviour.

Hardware setup:

Pentium 200 MMX
Kernel 2.4.26
Netgear PCI Prism card

WindowsXP / Linux Notebook

The AP is setup to Bridge between the wired and wireless network.
Trying to copy a file between two clients (one on the wired, the other 
on the wireless network)
I see the following behaviour.

WEP enabled:
	* Copying a file works in both directions without any problems

WEP disabled:
	* If I copy from the wireless to the wired client the throughput is 
	* Copying from the AP to the wireless client  works too.
	* If I copy from the wired to the wireless client I ONLY get around 30 
	   If I start tcpdump br0 on the AP throughput rises again to normal 

For testing purposes I configured the notebook to act as AP. Everything 
worked without a problem.

I tried the following things:

* Testing different versions of the hostap driver 0.1.x, 0.2.x, CVS
* Installing the same kernel as on the notebook to rule out a kernel or 
bridge code problem

So it is either a hardware fault,  although I doubt that since the card 
is working with WEP enabled, or something is wrong in the hostap_pci 
What really looks odd to me is that running tcpdump on the AP speeds up 
the transfer.

On a side note I see the following messages in dmesg every time I call 
iwconfig on the AP

wlan0 (WE) : Buffer for request SIOCGIWPRIV too small (16<88)
wlan0 (WE) : Buffer for request SIOCGIWPRIV too small (32<88)
wlan0 (WE) : Buffer for request SIOCGIWPRIV too small (64<88)

I know that this normally means that the wireless extensions between 
the driver and the tools are not in sync, but I am using the same 
versions on the notebook and don't see the messages there.

I am pretty sure that this is not a common problem and I can work 
around it (enabling WEP),
but maybe someone has an idea what might be happening here.


More information about the Hostap mailing list