WPA-PSK reconnection problem

Michael Guntsche mike
Tue Jun 1 07:24:18 PDT 2004

On Jun 1, 2004, at 1:39, Jouni Malinen wrote:
> Which version of hostapd are you using? Could you please re-test this
> with the current CVS snapshot of hostapd? Command line option -dd was
> not really used in the previous version and this log does not include
> all the information I would be interested in seeing. In addition, a bug
> in WPA rekeying was fixed some time ago.
I just tried it again with the current CVS snapshot and I still have 
the same problem.

> Which station firmware version are you using the card that is the AP? I
> tried to reproduce this with STA f/w v1.8.3, but did not see similar
> behavior.
Right now I am running with 1.8.0 but I also tried it with 1.8.3 (all 
volatile download).

Attached you'll find a full debug log with -dd.
The rekeying interval is set to 30 seconds. I connected, waited for one 
rekeying (AFAIR), then I turned of the wireless card, waited for 30 
seconds and turned it on again. No connection.

On a side note. After killing hostapd, I have to reload the firmware 
since, the card gets stuck and then resets itself. I am not sure if 
this is related to the WPA problem though.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: broken
Type: application/octet-stream
Size: 9681 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20040601/e00487d3/attachment.obj 
-------------- next part --------------

More information about the Hostap mailing list