Problems installing hostap on SuSE 9.0?

Mark G. Spencer mspencer
Wed Jan 21 10:49:33 PST 2004

I have also just tried compiling hostap from source.  Initially "make pccard" failed
as the kernel was not configured.  I configured the kernel using the recommended
command and "make pccard" worked.  I then ran "make install."  I rebooted the machine 
and ifconfig did not show any "wlan" items .. that didn't look good.  Checking dmesg, I
see that the prism2_cs is no longer loaded.

I only see a single line mentioning hostap:

"hostap_crypt: registered algorithm 'NULL'"

I've tried removing and replacing the SMC2532W-B, and I get the following in dmesg:

"hostap_crypt: unregistered algorithm 'NULL' (deinit)"
"hostap_crypt: registered algorithm 'NULL'"

Hopefully I didn't goof something trying to get the rpm working.  I can start from a
fresh install of the operating system if that sounds like a possibility ..


> ------------Original Message------------
> From: "Mark G. Spencer" <mspencer at>
> To: hostap at
> Date: Wed, Jan-21-2004 10:06 AM
> Subject: Problems installing hostap on SuSE 9.0?
> Today I made another run at getting hostap running on my Gateway 200 ARC notebook
> with a SMC2532W-B (Prism 2.5 chipset) PC Card.  I'm running SuSE 9.0 with the 
> latest updates.
> I used the SuSE rpm for hostap, which is hostap version 0.0.4-98.  After installing
> the rpm, I rebooted and checked the dmesg output.  prism2_cs was still being
> used, no mention of hostap.  Searching the filesystem for hostap*, I can see hostap 
> files have been distributed in a variety of locations by the rpm.


More information about the Hostap mailing list