Dlink DWL-520 Rev E1

Jake Snyder mr-mac
Sun Jan 18 15:35:15 PST 2004

I've been told that linux n00bs and wifi are a bad mix, but i'm 
attempting this anyway.  I purchased a DWL-520E and I've been following 
the threads on the DWL-520 E and the DWL-650 and i'm completely lost 
(well, not completely lost, but usually a little lost is not much 
different than completely lost).

I'm starting this from scratch, as i have no experience in the world of 
linux wifi.

As per the instructions, i downloaded the CVS snapshot under 
development branch and went to edit the "*pos++ = 0x03" and change it 
to "*pos++ = 0x07" but i cannot find this statement in the 
prism2_srec.h anywhere.  I've done searches for 0x03, pos++ and 0x07 
and i get nothing.  I also checked the tars and didn't find it either.

I figure while i'm waiting to find out where i'm supposed to modify 
this document i'll move on. So i went on to step 2.  If i understand 
correctly ( and it's more than possible that i don't) that i just 
uncomment the line that give "#define prism2_non_volitile_download"

Now, i tried building the hostap driver before finding this thread (the 
tarballs), do i do anything different when building this modified 
driver from cvs?

Andrew mentions loading the pci module with the no_primary set to 1, i 
read in the 650P thread to run "modprobe hostap_cs no_primary=1"  I 
know that the hostap_cs is for the pc cards and that hostap_pci is for 
the pci cards, which do i use?

I think i understand how to load the firmware in the card by using:
./prism2_srec -gs wlan0 pm010102.hex
./prism2_srec -gip wlan0 pm010102.hex
./prism2_srec -rp wlan0 rf010704.hex

  but where do i get the firmware i'm supposed to load.  I've read 
something about downloading it from the card, but i have no idea what 
this entails.

I appreciate all the help i've gotten from this thread already, and any 
additional help would be greatly appreciated.  I'm watching this list 
quite closely, as i find this a lot easier than all the stuff i tried 
under wlan-ng.

Jake Snyder
(mr-mac at qwest.net)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 2073 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20040118/82fc467b/attachment.bin 

More information about the Hostap mailing list