problem with downing wlan's

Steve Morris morris
Sun Jan 11 06:24:46 PST 2004

On Thu, Jan 08, 2004 at 12:18:40AM +0100, Vaclav Dvorak wrote:
> Jiri Fojtasek <jiri.fojtasek at> wrote:
> >Vaclav Dvorak wrote:
> >>>I wanted to try rmmod-ing hostap_pci to see whether it helps, and it 
> >>>doesn't seem to work. I did "ifconfig wlan0 down; ifconfig wlan1 down; 
> >>>rmmod hostap_pci", and it hung the machine. So the next time the 
> >>>machine booted, I tried the commands one by one. The ifconfig's 
> >>>succeeded, but the rmmod never finished, although this time it didn't 
> >>>hang. Instead, the log said: "kernel: unregister_netdevice: waiting 
> >>>for wlan1 to become free. Usage count = 2", and the message repeated 
> >>>approximately once every 10 seconds.
> >>>
> >>>Hostap is 0.1.2.
> >>>
> >
> >I have this problem in one box where i using bridge with ebtables patch 
> >and imq device. I have found that this is imq device related problem. It 
> >sometimes forgot to use dev_put() after dev_hold(). What is your setup ?
> I am not using the IMQ device, nor the bridge, much less ebtables. The 
> kernel is not patched with anything.

I am having similar problems with kernel 2.6.[01] and hostap-driver-0.1.2.

Here's my down script:

/etc/init.d/dhcp3-server stop
ifconfig wlan0 down
rmmod hostap_crypt_wep
rmmod hostap_pci
rmmod hostap

after I run rmmod hostap_pci I get a 'Segmentation fault' and while my
machine is still running, trying to do 'lsmod' just hangs.

moe:/usr/local/src/hostap# rmmod hostap_pci
Segmentation fault
moe:/usr/local/src/hostap# lsmod
Module                  Size  Used by

I'll be happy to generate some debug info if someone can tell me what
they need and how to do it.


> -- 
> Vaclav Dvorak  <vdvo at>
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the Hostap mailing list