DWL-650 rev P - no progress with CVS hostap..

Joshua Kwan joshk
Sat Feb 28 17:50:27 PST 2004

Hi all, 

I read the two threads about getting D-Link 650 rev P to work with
hostap_cs. I tried Pavel Roskin's method but his dmesg messages were not
the same as mine. Here is what I have when I insert my 650:

(Note: i tried to load module with no_primary=1, but it wasn't

hostap_crypt: registered algorithm 'NULL'
hostap_crypt: registered algorithm 'WEP'
hostap_cs: CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0047, io.base=0x0000, len=128
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0200-0x027f
wifi0: init command completed too quickly - retrying
wifi0: __hfa384x_cmd_no_wait(6) - timeout - reg=0xffff
hostap_cs: first command failed - assuming card does not have primary firmware
hostap_cs: assuming no Primary image in flash - card initialization not completed
wifi0: test Genesis mode with HCR 0x1f
prism2_pccard_cor_sreset: original COR 41
prism2_pccard_genesis_sreset: original COR 41
Readback test failed, HCR 0x1f write 00 e1 a1 ff read 00 ce a1 ce
wifi0: test Genesis mode with HCR 0x0f
prism2_pccard_cor_sreset: original COR 41
prism2_pccard_genesis_sreset: original COR 41
Readback test succeeded, HCR 0x0f
prism2_pccard_genesis_sreset: original COR 41
wifi0: registered netdevice wlan0
prism2: wlan0: operating mode changed 3 -> 2
wlan0: cannot set RID fc00 (len=2) - no PRI f/w
wlan0: cannot set RID fc02 (len=34) - no PRI f/w

I tried to write the primary firmware, but:

# ./prism2_srec  -g wifi0 primary/pm010102.hex 
srec summary for pm010102.hex
Included file name: PM010102.HEX
Component: 0x0015 1.1.2 (primary firmware)

ioctl[PRISM2_IOCTL_HOSTAPD]: Inappropriate ioctl for device
Missing wlan component info
Could not read wlan RIDs

What do I need to do in order to get this card working?


Joshua Kwan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 827 bytes
Desc: Digital signature
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20040228/af7d7422/attachment.pgp 

More information about the Hostap mailing list