Linksys WPC11, can load drivers (manually) but doesnt create device wlan0.

Jerry mrcool
Sat Jan 25 07:32:39 PST 2003

Jason wrote:
>Well, what I do is in /etc/modules.conf (or in my case
>/etc/modutils/aliases on Debian) is add:

>alias wlan0 hostap_pci

>I always have my precious wlan0 now.

Jouni wrote:
> That sounds like your pcmcia-cs (actually, cardmgr) is configured to use
> prism2_cs driver. If you want to use Host AP driver with that card, you
> would need to change pcmcia-cs configuration for that card. Host AP
> driver installation should have already copied hostap_cs.conf that
> describes hostap_cs.o as the driver for Linksys WPC11. However, some
> other configuration file can override this configuration. You would thus
> need to comment out that other part refering to prism2_cs driver.

Thanks Jouni, Jason...

Jason:  ...had tried that already, its in /etc/modules.conf. doesnt make any

Jouni:  I think you are right.  But, Im a realtive newb to linux, and since
i use SuSE (which has all kinds of wizards and such that work so well) im
not familiar with ALL the little text files in etc that configure things...
Does anyone know, perhaps, which config files i need to modify to make
cardmanager load host_ap instead of prism2_cs?

Oh, and i do have the hostap_cs.conf updated to what my linksys card has
when you type 'cardctl ident', i have actually tried several different
incarnations of this...


More information about the Hostap mailing list