HostAP and xsupplicant

Dimitris Theofilatos thed
Mon Jan 20 08:31:11 PST 2003

On Tuesday 14 January 2003 03:00, Jouni Malinen wrote:
> On Mon, Jan 13, 2003 at 03:13:25PM +0000, Dimitris Theofilatos wrote:
> > Does anyone know if the HostAP code interworks with the xsupplicant code
> > from open1x? I followed the instructions from the site
> > I used 3 linux machines with
> > RedHat 7.3 and kernel 2.4.18. I used hostap-2002-10-12 driver and the
> > latest version of xsupplicant (xsupplicant-0.5)  but when the xsupplicant
> > sends the first EAPOL Start message the hostapd daemon unauthorize the
> > station.
> I tested xsupplicant v0.5 today, but it segfaulted when I tried to
> authenticate.. I didn't yet have time to check why. Anyway, older
> version of xsupplicant work fine with the same certificates and
> configuration using hostapd as Authenticator and FreeRADIUS as
> Authentication Server.
> Authenticator state machines set the port into unauthorized state when a
> new station is added so it is OK to get that messages after EAPOL-Start.
> The port is authorized for the first time only after successful
> authentication has been completed.

I used an older version of xsupplicant and the last CVS version of hostap and 
it worked with the minimal authentication server of the hostap. 

But i had a problem when i used another machine for RADIUS. I enabled routing 
at the machine which was acting as an Access Point and i saw that the Access 
Point sends an EAP-Request/Identity at the supplicant, the supplicant 
responds with a EAP-Response/Identity, then the AP sends an Access-Request to 
the Radius server, the Radius responds with an Access-Challenge but the 
authenticator does not forward this message to the supplicant. Do you know 

Thanks in advance

More information about the Hostap mailing list