hostap doesn't understand wireless commands

Praedor Atrebates praedor
Mon Feb 17 10:19:35 PST 2003

I have built and rebuilt the hostap driver to no avail.  I am running Mandrake 
9.0 on an IBM Thinkpad.  Kernel is 2.4.19-16mdk.  The module loads fine upon 
initial insertion of the prism2 card but it insists on going into managed 
mode, channel 4, with essid "test".  I have editied my 
/etc/pcmcia/wireless.opts so that it would be ad-hoc, channel 6, essid tower.  
Why is this being ignored?  I have also tried setting up the device at bootup 
by editing ifcfg-wlan0 so that it contains the proper data.  Ignored, just as 
wireless.opts is ignored.

I then try to use iwconfig but hostap refuses to understand/accept any 
command.  Upon initial insertion of the card, if I run iwconfig I get 
essid:"test" Mode:Master Freq:2.422GHz.  NO NO NO!  I then try to set it with 
iwconfig to be correct: "iwconfig wlan0 mode ah-hoc" and the result is a 
pause of about 3 seconds then:

Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; 
Invalid argument.

This does change the card to ad-hoc mode but then totally borks the ability to 
change anything else short of restarting pcmcia services (and then being 
right at square one again).

I am using the latest wireless tools and the kernel is about as new as you can 
get and still be reasonably stable.  It DOES include the latest available 
wireless extensions.  I just built the hostap driver for this kernel.  Why 
can't it understand and accept perfectly valid config commands?  What is 
going on here.  Oh, once I try to set the card manually with iwconfig, the 
display of info produced by iwconfig drops to a bare minimum to only include 
the Mode, Tx-Pwr, Encryption key, and signal/noise levels.  No channel, no 
freq.  Any attempt to set channel or freq results results in failure:

Error for wireless request "Set Frequency"(8B04);
SET failed on device wlan0; Invalid argument.

NO NO NO.  IT IS A VALID FRICKIN ARGUMENT.  Its rejection is invalid.  Can 
anyone explain the problem and how to get around it here?  What file is 
hostap looking to for initial setup params?  


More information about the Hostap mailing list