INFDROPs during large file transfers

Michael Guntsche mike
Wed Apr 16 08:45:41 PDT 2003

Sorry if this has been solved already, but I searched the archives and
didn't find anything.

My setup:

	Pentium 200
	kernel 2.4.20 patched with W15
	Netgear M301 as master
	STA: 1.5.6 RAM upload

	Pentium 266
	kernel 2.4.21-pre6 + ACPI patches
	Netgear MA411 in managed mode
	STA: 1.3.6 (also tried 1.5.6 RAM)

Both running the latest CVS version of hostap

Problem Description:

If I transfer (scp) a large file (> 2MB) from one machine to the other,
dmesg on the notebook shows me a whole bunch if INFDROPS after some
time. The transfer doesn't seem to be affected by it.
I tried different kernel and STA version, no change.

Then I tried different combinations.

Copying a file via scp (20MB):

WEP disabled:
	AP 		-> 	notebook 570KB/s 	no INFDROPS on notebook
	notebook	->	AP	 437KB/s	sometimes INFDROPS

WEP enabled:
	AP		->	notebook ~520KB/s	immediate INFDROPS on notebook
	notebook	->	AP	 ~180KB/s	sometimes INFDROPS

The INFDROPs could be hardware related but Im not quite sure how to find
that out. Both cards are new so I think they are ok.
The problem thats irritates me the most is the 180KB transfer rate I
get from the notebook to the AP in WEP mode. During the transfer the
load is normal on both machines.
Maybe someone can help me to debug this further.

Thanks in advance,


More information about the Hostap mailing list