problem of running WDS with 802.1x

mario mario
Wed Apr 16 18:58:21 PDT 2003


I have tried WDS and 802.1x features of hostap version 0.0.1. They work individually. However, WDS fails when running with 802.1x. When running 1x, APs will generate different keys for their wireless link. It is perfectly okay. However, the problem is each AP will uses its key for the WDS link as well. Since both ends of WDS link use different keys, the WDS link fails.

I use the same WDS configuration as mentioned in README.prism2. It worked in the previous version of hostap as well as the latest version when not running 1x. WDS only fails with 1x running. Perhaps, I have missed out something. Could someone give me any advice?

Also, does anyone has any experience of upgrading linksys STA firmware under linux? I have some physical constraint of unplugging Linksys card from my embedded system and plug it to a Wins system for firmware upgrade.

I would very much appreciate your help.

With regards,
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list