Get_iplayer no longer converts to m4a

Steve Rochford steve.rochford at
Mon Jun 6 10:20:07 PDT 2022

You shouldn't need to make any changes to the path. The batch file get_iplayer.cmd works out the folder it's being run from, and then temporarily changes PATH to include perl\bin and utils\bin underneath that folder. Can you check that your batch file looks like this:

@echo off
set GIP_INST=%~dp0
if #%GIP_INST:~-1%# == #\# set GIP_INST=%GIP_INST:~0,-1%
if "%GIP_PATH%" == "" set GIP_PATH=%GIP_INST%\perl\bin;%GIP_INST%\utils\bin;%PATH%
if not "%GIP_PATH%" == "" set PATH=%GIP_PATH%
perl.exe "%GIP_INST%\" %*

to check that it's working, add:

echo %path%

immediately before the perl.exe line and run it - it should show you the value of PATH, wait for you to press a key and then run. One possible problem is that your existing PATH is too long, but I doubt that's the issue - by adding the GIP folders to the start of the existing path you might break other apps (but only while GIP is running).

Your version of ffmpeg is way out of date - I can understand that you might get the errors while it's running saying the version is too old, but I don't think that it would give the "no such file" error that you're seeing. There's a current version of ffmpeg for Windows here - You need to download, unpack it with 7-Zip and copy the ffmpeg.exe file from the bin folder to the utils\bin folder under get_iplayer.

Good luck!


-----Original Message-----
From: get_iplayer <get_iplayer-bounces at> On Behalf Of Jonathan Bryden
Sent: 06 June 2022 12:29
To: mail at
Cc: get_iplayer at
Subject: RE: Get_iplayer no longer converts to m4a

Update - I tried uninstalling, restarting and re-installing (the 64 bit version this time) and I am still getting the same error message (though with the path changed from Program Files (x86) to Program Files) so now I am completely at a loss.

INFO: Converting to M4A
open3: IO::Pipe: Can't spawn-NOWAIT: No such file or directory at C:\Program Files\get_iplayer\ line 2120.

Help anyone???

-----Original Message-----
From: get_iplayer <get_iplayer-bounces at> On Behalf Of J K.Eason
Sent: 06 June 2022 11:44
To: get_iplayer at
Subject: Re: Get_iplayer no longer converts to m4a

> *From:* Chris Walker <cdw_pcmail at>
> *To:* get_iplayer at
> *Date:* Mon, 06 Jun 2022 11:17:40 +0100
> On Mon, 2022-06-06 at 10:00 +0000, Jonathan Bryden wrote:
> > Hi
> > 
> > Thanks so much for all your ideas - unfortunately no success so far.
> > 
> > The same message appear for both TV and radio and both download a 
> > .TS file before stopping.
> [snip]
> > This is a mystery to me - any further ideas would be most welcome...
> How about adding the location of ffmpeg to your options file?
> Take a look here -
> ;data=05%7C01%7C%7Cf0dbf5ac4e1a43ed627b08da47afdb55%7C84df9e7fe9f640af
> b435aaaaaaaaaaaa%7C1%7C0%7C637901117858154489%7CUnknown%7CTWFpbGZsb3d8
> eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3
> 000%7C%7C%7C&sdata=4XwTA8OV%2F5fP7Iw9Uj5ppK53fj6Uxx6SvBGnPpPLyFg%3
> D&reserved=0
> gram-options for how to add it.
> I don't use Windows for GiP so I can't offer any suggestions about how 
> you would keep ffmpeg updated but doubtless there are others on here 
> who can advise on that.

It should be updated automatically every time you install a new version of GIP.


get_iplayer mailing list
get_iplayer at

get_iplayer mailing list
get_iplayer at

More information about the get_iplayer mailing list