Error free HLSHD

RS richard22j at
Sun Aug 28 07:04:17 PDT 2016

>From: Simon Morgan
>Sent: Sunday, August 28, 2016 11:58 AM

>INFO: 1 Matching Programmes
>INFO: Checking existence of editorial version
>high1,hvfstd1,hvfstd2,hlsstd1,hvflow1,hvflow2,hlslow1 modes will be tried
>for version editorial

>ERROR: Failed to download segment (265)
>ERROR: Segment URL:

>INFO: Recorded: 1279.53MB in 02:38:32 at  1102kbps to F:\iplayer
>WARNING: Retry recording for 'David Attenborough's Zoo Quest in Colour - -

>ERROR: Cannot instantiate streamer for class=Streamer:: version=editorial
>INFO: skipping this programme
>ERROR: Failed to record 'David Attenborough's Zoo Quest in Colour - -
>Recording complete

The first comment to make is that this is not the problem with HLS which has 
been plaguing us for the last month or so and now seems to be fixed.  You 
are downloading HVF, hvfhd1, and not HLS.

There are two types of error.  dinky criticised users reporting errors (I 
think he meant me!) for not distinguishing them.  I was referring to errors 
because I thought everyone knew we were talking about HLS Segment not found 
errors.  The Segment not found error as it was called in v2.95 has had its 
description changed in v2.96 to something like Unable to find segment on 
server.  What it means is that something has gone wrong in the segmenting 
process by Akamai, and the segment does not exist on the server.  There is 
no point in retrying because the segment is not there.  It was this type of 
error we were experiencing more and more frequently with HLS.

You have the other type of error, Failed to download segment.  This is only 
the second instance of this type of error I have ever seen.  The other one 
also occurred with HVF.  I understand it has a wider range of possible 
causes, so get_iplayer retries.  dinky says it retries twice.  I thought I 
saw more retries than that but I haven't kept the screen display so I can't 
argue.  In my case the retries just made another unsuccessful attempt to 
download the failed segment.  In your case a completely different error has 
occurred on the retry.

I had understood that in v2.96 an error of this type was to cause the next 
mode in the list to be tried.  That has not happened.

In my case I tried to reproduce the error the following day, but it had gone 
away.  You could try again in a few hours, but I see you have a very slow 
internet connection.

I have not used v2.96 yet so I can't comment from my own experience.  I was 
surprise at the list of modes listed to be tried.  I had understood the 
default in v2.96 was to be HVFSD.  In your case it has defaulted to hvfhd1. 
I had also understood in v2.96 that HLS was to be removed from being a 
default, yet hlshd1 appears in the third position of modes to be tried.

Another curiosity is that it has attempted to download the editorial 
version.  You'll have to ask someone else the significance of that.

More information about the get_iplayer mailing list