Audio/Video Out of Sync

Jim web web at
Fri Aug 12 05:18:58 PDT 2016

This morning I had increased problems fetching a TV programme.

The item has pid b07nwk5h. I initially tried using an 'old' method to avoid
the difficulties with HLS that were causing fetches to end prematurely.
However this morning before 9am this 'old' method using

 --type=tv --mode=best --no-tag --pid <>

started an "RTMPDump" which terminated abruptly having fetched less than
the first minute of the programme file.

I tried HLS for comparision, using what used to be fine until a few weeks

--tvmode=hlsbest --no-tag --pid <>

But this also terminated with less than the first min obtained.

I then tried

--tvmode=best --no-tag --exclude-supplier=akamai --pid <>

This fetched the programme OK via "RTMPDump" and completed OK. However
whereas the previous methods had started fetching 1280x720 this only got me
a 832x468 version. It seems complete, but obviously has less detail.

Not knowing what was going on I then tried out combining --tvmode=hlsbest
with --exclude-supplier=akamai. This failed telling me the relevant modes
weren't available.

I can try again to see if anything changes, but any insight or advice or
suggested alternatives would be welcome. Having to use the 'old' method is
awkward because it is slower. But at least until this morning it was
working. However for the above, it failed.

Separate to the above. Using the mpeg-dash method to fetch 320k Radio seems


Armstrong Audio
Audio Misc

More information about the get_iplayer mailing list