Does RTMP still have the 4GB problem?

Alan Milewczyk alan at
Sun Jul 5 17:34:50 PDT 2015

On 06/07/2015 00:11, C E Macfarlane wrote:
> I've been encountering problems playing back some of the long Wimbledon
> programmes.  The files play so far, and then hang.  I suspect that this is
> the rtmpdump 4GB problem which some research threw up, and that I am going
> to have to split the downloads using --stop and --start parameters.
> However, given that the downloads are very large and my download speeds are
> very slow, I thought I'd better to check here that I've analysed the problem
> correctly, before redownloading any material.
> Can anyone here confirm that rtmpdump still suffers from the problem?  If
> so, is anything being done about it?  It seems to me that this should be a
> relatively trivial problem to fix.

Funny you should say that, but I'm having the same problems on the large 
Wimbledon files!

I normally use Win7 X64 but decided to try Linux Mint (which worked for 
me last year) but with all long programmes, the download hangs at the 
4Gb mark.

So I tried Win7 again, the original RTMP results in a download that 
stops and starts around the 4GB limit but finishes downloading. When the 
flash file is converted to mp4, it plays fine up to around 3 hrs 50 mins 
or so then hangs.

I then tried the patched RTMP (see 
- the download seemed smoother, with only a few stops and starts, but in 
the end it didn't matter as it produced a file with many many many 
"missing picture in access unit" errors when being converted to mp4 - 
it's unwatchable because it jumps and stutters all the way through.

I then referred to a message/reply on this subject posted to me by 
Vangelis on 25th May:

"In addition to DP's binary, which is now somewhat stale but should be 
fine for GiP usage, you can also use KSV's (a Russian coder) rtmpdump 
mod, which lately also got support for  > 4GB files on Windows: 

> Update 01/05/2015:
> 1. save and resume support for more than 4 GB files

(Safe and trusted download from github, used it successfully for > 4 GB 
files on Win32). "

Well, I have just tried that and get the same result as using the modded 
DP binary! :-(

I don't know if anyone else has tried this with better results (I'm 
downloading programmes from the following page: Time for bed for today, 
tomorrow's another day to try things anew. Incidentally, the only thing 
I haven't done so far is use the modded RTMP files on Linux Mint as I 
don't have a clue how to mod the original executable on Linux.

I'll probably be asking you for instructions as to how to use the 
"--stop/--start parameters". I didn't know you could do this.... Enough 
for tonight.

Nite all!


More information about the get_iplayer mailing list