Not picking up available HD stream

dinkypumpkin dinkypumpkin at
Wed May 22 16:23:40 EDT 2013

On 22/05/2013 17:34, Neill Mitchell wrote:
> Sorry, just to clarify, other HD content comes down at HD resolution. Dr
> Who doesn't every single time. I see other oddities as well. For
> example, the Sky at Night, which is not HD comes down at 640x360 as well.
> In the options file I have tried modes=best as well as
> modes=flashhd,flashhd2,flashvhigh,flashvhigh2,flashhigh,flashstd
> This makes no difference. When I run get-iplayer --pvr I can see the
> modes line is as above. It's as it if just chooses to ignore it on some
> programmes.
> The only way is to download again via the pid and specify just the hd mode:
> get-iplayer --get --pid <PID> modes=flashhd --force
> For the Sky at Night example I specify mode=flashvhigh as the mode and
> then it comes down at 832x468.
> This is on Ubuntu 12.10 with the latest ppa version.
> Any ideas why it is doing this? It started doing it about 2 weeks ago.

No way to know without seeing a log.  First, try to download one of the 
offending Doctor Who episodes with --show-options added and see if the 
values are as you expect.  If it still isn't obvious what's wrong, try 
the same command with --verbose added (and --show-options removed), 
upload the log to a pastebin site and post the link, and I'll take a 

More information about the get_iplayer mailing list