Not picking up available HD stream

Neill Mitchell neill at
Wed May 22 12:34:06 EDT 2013

Sorry, just to clarify, other HD content comes down at HD resolution. Dr Who doesn't every single time. I see other oddities as well. For example, the Sky at Night, which is not HD comes down at 640x360 as well.

In the options file I have tried modes=best as well as modes=flashhd,flashhd2,flashvhigh,flashvhigh2,flashhigh,flashstd

This makes no difference. When I run get-iplayer --pvr I can see the modes line is as above. It's as it if just chooses to ignore it on some programmes.

The only way is to download again via the pid and specify just the hd mode:

get-iplayer --get --pid <PID> modes=flashhd --force

For the Sky at Night example I specify mode=flashvhigh as the mode and then it comes down at 832x468.

This is on Ubuntu 12.10 with the latest ppa version.

Any ideas why it is doing this? It started doing it about 2 weeks ago.


>>Message: 1
>>Date: Wed, 22 May 2013 16:54:39 +0100
>>From: Neill Mitchell <neill at>
>>To: get_iplayer at
>>Subject: Re: Not picking up available HD stream
>>Message-ID: <519CEA3F.70003 at>
>>Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>>I'm seeing this as well. For example, Dr Who comes down at 640x360 if I
>>run get-iplayer with its defaults.

More information about the get_iplayer mailing list