Size of flashvhigh video is incorrectly only the size of flashhigh

ode ode5002 at
Sat Aug 10 17:47:35 EDT 2013

Hello, I downloaded

The modes for the program are:

I use 'get_iplayer --nopurge -g --modes=best' to download, expecting to
get a 4.7GB file. But actually I only get a 2.5GB file.

The output when I run the download command is:
get_iplayer v2.83, Copyright (C) 2008-2010 Phil Lewis
  This program comes with ABSOLUTELY NO WARRANTY; for details use
  This is free software, and you are welcome to redistribute it under
  conditions; use --conditions for details.

80:     Athletics - World Championships: 2013: Day 1, Part 4, BBC Sport,
Athletics,Sport,TV, default

INFO: 1 Matching Programmes
INFO: Checking existence of default version
INFO: flashvhigh1,flashvhigh2,flashhigh1,flashhigh2,flashstd1,flashstd2
modes will be tried for version default
INFO: Trying flashvhigh1 mode to record tv: Athletics - World
Championships: 2013: Day 1, Part 4
INFO: File name prefix =

RTMPDump v2.4
(c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
Connecting ...
INFO: Connected...
Starting download at: 0.000 kB
INFO: Metadata:
INFO:   duration              12874.75
INFO:   moovPosition          2409707242.00
INFO:   width                 832.00
INFO:   height                468.00
INFO:   videocodecid          avc1
INFO:   audiocodecid          mp4a
INFO:   avcprofile            77.00
INFO:   avclevel              30.00
INFO:   aacaot                2.00
INFO:   videoframerate        25.00
INFO:   audiosamplerate       24000.00
INFO:   audiochannels         2.00
INFO: trackinfo:
INFO:   length                321866000.00
INFO:   timescale             25000.00
INFO:   language              eng
INFO: sampledescription:
INFO:   sampletype            avc1
INFO:   length                308994048.00
INFO:   timescale             24000.00
INFO:   language              eng
INFO: sampledescription:
INFO:   sampletype            mp4a

As you can see it is successfully connecting to the flashvhigh stream
but I am only getting the flashhigh file size.

I am using a the latest version of get_iplayer from git on Linux.


P.S. I just noticed that the same thing is happening on Athletics -
World Championships: 2013: Day 1, Part 3.

More information about the get_iplayer mailing list