Get_iplayer on Raspberry Pi

Alex Eames alex at
Thu May 31 12:39:38 EDT 2012

On 31/05/2012 15:10, tommy wrote:
> On 31 May 2012 14:21, Alex Eames<alex at>  wrote:
>> I now get a whole bunch of messages like this...
>> ERROR: RTMP_ReadPacket, failed to read RTMP packet header
> I had a similar problem initially but solved itself when I ran it
> again - could it be an environment variable issue? Try logging out and
> in again...
That didn't clear it. I even switched users. I got fed up with not being 
able to read/write access my usb stick so I'm logging in as root now. It 
didn't help switching users, rebooting. Shutdown.

But I have now seemingly got it working after running rpi-update 
(hexxeh's firmware updater).
I ran this a few days ago, but something must have fallen into place by 
updating to the very latest firmware.

Just completed a low res download and transcode. Half-way through an HD 
download. It hasn't given any timeout messages yet. Will see how stable 
it is. File downloaded, now transcoding. :) No timeouts. FFMPEG is 
taking about 31-35% CPU time much as it did before (well I haven't 
changed it yet).

Thanks Tommy and dinkypumpkin for all your help. I'm cautiously 
optimistic that it's OK now.
I'll do an FFMPEG compile when I've finished testing the download process.

Oh - and the other interesting thing is that the new rtmpdump 2.4 seems 
to hover around 21% cpu
whereas 2.3 seemed to take about 30% (or maybe my connection's running 
slower? LOL)

Thanks guys :)

More information about the get_iplayer mailing list