Itouch mp4 settings

Andy Bircumshaw andy at
Fri Dec 24 07:32:12 EST 2010

This list really isn't the place to address ffmpeg problems.

I am not an expert on transcoding - that's just the kind of thing I'll avoid at all costs, if possible.

Better to join the ffmpeg list and ask there.

However, a couple of comments below:

On 24/12/2010, at 10:43am, Don Rossie wrote:
> ...
> I am afraid that I am getting to the end of my tether with this problem of
> itouch recordings.
> I have tried ffmpeg with the following settings:
> For one pass:
> ffmpeg -i INPUT -acodec libfaac -ab 128k -s WIDTHxHEIGHT -vcodec libx264
> -vpre slow -vpre ipod640 -b BIT_RATE -aspect WIDTH:HEIGHT -threads 0 -f ipod
> OUTPUT.mp4
> When I run this I get the error saying that it can't find the preset "slow".

This looks to me like you're specifying the slow preset and then overriding it with the ipod640 preset, anyway.

What happens if you remove the "-vpre slow"? 

> I have tried putting the 'libx264-slow.ffpreset' into root of the ffmpeg
> directory, renaming it slow and renaming it to slow and putting it back into
> the ffmpeg presets directory.

man ffmpeg says:

       Preset files are specified with the "vpre", "apre", "spre", and "fpre"
       options. The "fpre" option takes the filename of the preset instead of
       a preset name as input and can be used for any kind of codec. For the
       "vpre", "apre", and "spre" options, the options specified in a preset
       file are applied to the currently selected codec of the same type as
       the preset option.
       The argument passed to the "vpre", "apre", and "spre" preset options
       identifies the preset file to use according to the following rules:
       First ffmpeg searches for a file named arg.ffpreset in the directories
       $FFMPEG_DATADIR (if set), and $HOME/.ffmpeg, and in the datadir defined
       at configuration time (usually PREFIX/share/ffmpeg) in that order. For
       example, if the argument is "libx264-max", it will search for the file
       If no such file is found, then ffmpeg will search for a file named
       codec_name-arg.ffpreset in the above-mentioned directories, where        
       codec_name is the name of the codec to which the preset file options
       will be applied. For example, if you select the video codec with
       "-vcodec libx264" and use "-vpre max", then it will search for the file

> As this didn't work, I tried FFE with all of the Vob to h264+AAC preset and
> get the following error message:
> [NULL @ 003f3c80] [Eval @ 0022fa78] Invalid chars 'v' at the end of
> expression '4mv'
> [NULL @ 003f3c80] Unable to parse option value "4mv+trell+aic+umv+qpel"
> Invalid value '+4mv+trell+aic+umv+qpel' for option 'flags'
> If you can offer any further help, I would be very grateful

That looks like the .ffpreset file contains dodgy characters. Could it be corrupt? What platform are you using? If on Windows, could it contain the "wrong kind" of line-feed characters?


More information about the get_iplayer mailing list