booting from network with fc6 or fc7t2 / Apple G4 PPC ? yaboot ?

Pierre Bourgin pierre.bourgin at
Mon Mar 5 06:03:02 EST 2007


Can someone has any advice about netbooting Apple Mac PowerBook G4 based 
to install FC6 ? or has a status about it ?

I try to use yaboot from TFTP server with the OpenFirmware command
" boot enet:0,yaboot ".

the vmlinuz file is successfully transfered, the ramdisk.image.gz 
transfert begins but fail to be achieved with the following error:

Transfer FILE: /ppc32/fc6/ramdisk.image.gz method 'load' failed 00000300
ramdisk load failed !

I've also tried with the netboot image via yaboot, but it fails with the 
same error message the previous one (for ramdisk.image.gz).

It also fails if trying to boot it directly from OpenFirmware (" boot 
enet:O,/ppc32/fc6/netbooot-ppc32.img ").
BTW, is it a right method to load it, or the use of yaboot is required ?

Some googling seem to indicate that the file to load via yaboot are too 
big ?

So I've built the last yaboot available from sources (1.3.14-rc1), but 
errors messages remain the same.

I've also tried to load vmlinuz/ramdisk.image.gz of FC7-t2, but it also 

Did I missed something ?

Also is it a yaboot limitation while booting from network ? no such 
limitations while booting from a physical media (cdrom) ?

I must say that this is pretty difficult to find some infos. about this 
:( and the Fedora wiki pages about PPC is pretty tiny.

Thanks in advance for  any tips !


The Network-on-Chip Company

More information about the Fedora-ppc mailing list