[PATCH v2 2/5] usb: dwc2: add clk dependency for probe via oftree
Sascha Hauer
sha at pengutronix.de
Wed Jan 6 03:57:38 EST 2021
On Thu, Dec 17, 2020 at 12:07:28PM +0100, Michael Grzeschik wrote:
> The dwc2 controller at least needs one core clock which needs to be
> enabled before it is able to address the core registers. This patch adds
> the referenced clock in the devicetree to be used.
>
> Signed-off-by: Michael Grzeschik <m.grzeschik at pengutronix.de>
> ---
> drivers/usb/dwc2/core.h | 1 +
> drivers/usb/dwc2/dwc2.c | 19 +++++++++++++++++--
> 2 files changed, 18 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/dwc2/core.h b/drivers/usb/dwc2/core.h
> index b9845b5524..780efb262c 100644
> --- a/drivers/usb/dwc2/core.h
> +++ b/drivers/usb/dwc2/core.h
> @@ -467,6 +467,7 @@ struct dwc2 {
> struct dwc2_core_params params;
>
> struct phy *phy; /* optional */
> + struct clk *clk;
>
> #ifdef CONFIG_USB_DWC2_HOST
> struct usb_host host;
> diff --git a/drivers/usb/dwc2/dwc2.c b/drivers/usb/dwc2/dwc2.c
> index 82b5ef2813..13455479ef 100644
> --- a/drivers/usb/dwc2/dwc2.c
> +++ b/drivers/usb/dwc2/dwc2.c
> @@ -50,15 +50,26 @@ static int dwc2_probe(struct device_d *dev)
> dwc2->regs = IOMEM(iores->start);
> dwc2->dev = dev;
>
> + dwc2->clk = clk_get(dev, NULL);
According to the binding doc the clock should be named "otg", I think
this should be changed accordingly.
Sascha
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
More information about the barebox
mailing list