Scrolling issues in edit command

Guillermo Rodriguez Garcia guille.rodriguez at
Tue Apr 5 00:52:39 PDT 2016

2016-04-04 22:07 GMT+02:00 Uwe Kleine-König <u.kleine-koenig at>:
> Hello,
> On Wed, Mar 30, 2016 at 05:38:53PM +0200, Guillermo Rodriguez Garcia wrote:
>> I am trying to setup Barebox on a SAMA5D3-Xplained board. I started
>> with barebox-2016.03.0. So far things are looking good.
>> I have found that I have problems in the 'edit' command, when trying
>> to scroll using the arrow keys. Scrolling up inserts random "A"
>> characters in the text, scrolling down inserts random "B" characters.
>> I am using minicom as the terminal. I don't remember seeing this
>> before with older versions of barebox on different boards.
> Can you instrument your serial driver to count/notice overflow events?

You mean in barebox, or in the host where I'm running minicom/microcom?

> It's strange that you're missing chars 3-12 in a longer paste.
> Does it help to use
>         busybox microcom -d 10 ...
> ? (That is a feature that is missing from the "fullblown" microcom that
> comes in the microcom package.)

Interesting. I tried that, the result is:

- Still the same problem when scrolling up and down in "edit" (A and B
characters inserted)
- Many more missing chars when pasting "Lorem ipsum.." (_in "edit"_).
Here are three examples:

Loe Ismismyuye   iinatestis.
Loe Ismismyuye  eiinatest uy.
Loe Ismismyuye   iinatest uy.

- The very same text can be pasted perfectly in barebox's command
line, no missing chars. The problem is only with the "edit" command.
What makes "edit" different ?


More information about the barebox mailing list