[RFC][PATCH] pcm043: usb support --not working--

Michael Burkey mdburkey at gmail.com
Tue Nov 6 14:48:32 EST 2012

Sascha Hauer <s.hauer at ...> writes:

> On Wed, Aug 01, 2012 at 11:04:38PM +0200, Christoph Fritz wrote:
> > On Wed, 2012-08-01 at 18:56 +0200, Eric Bénard wrote: 
> > > > The clock settings seems to be the same as for eukrea_cpuimx35. Eric:
> > > > Does USB work for you on your board?
> > > > 
> > > thanks for the heads up : now it works.
> > 
> > great 
> > 
> > > > Sascha, I currently have no working config for kernel >=3.5 to check for
> > > > clocks in debugfs.
> > > > 
> > > > Any thoughts on this?
> > > > 
> > > try to copy the config in that patch I just sent 
> > 
> > I did - without success. I suppose the external phy needs to be
> > configured properly.
> > 
> > When you type the command "usb", you are getting a list of connected
> > devices. Can you execute command "usb" a second and third time with the
> > same result?
> By default 'usb' now only probes once. That is because the USB stack is
> too silly to just keep already enumarated devices, but instead just
> removes all devices and reenumarates them. Bad things happen if one of
> your devices was a mounted USB mass storage device for example.
> If you want to probe multiple times try the -f aka force aka I know what
> I'm doing option.
> Sascha


I work with Jerry and I've been doing a lot more testing with USB lately and 
we are still having issues under Barebox. We are on new hardware that now 
uses the internal Phy and everything seems to work find under Linux itself.
However,under Barebox I am still seeing the following behaviour:

1) The first time after reset, when I do the "USB" command it detects the
built-in hub device and any HID devices I have tested without issue. 
2) Any additional times I do "USB -F" after that it ONLY detects the
internal hub.
3) USB Mass Storage devices (flash drives, hard drives, et al) are NEVER
detected -- and I've tried a LOT of different ones. The vast majority are
never even detected at all, but I have one really old one that it will at
least say "2 devices detected" on the probe but never shows any description
of the device.

We are using a PCM043 SOM on a custom carrier board -- and to the best of 
my knowledge everything is setup properly. I've also checked the USB clock
and it is correct. I have so far tried this with both Barebox 9 and Barebox
10, with no success. I have made sure that USB support is compiled in, as
well as mass storage support and FAT support.

Do you have any ideas as to what might be going on or what we should be 
looking at? 

Michael Burkey

More information about the barebox mailing list