Booting PhyTec PCM043/IMX35 from USB/SD-Card

Peter Kuennemann@Crane-Soft pkue at
Fri May 25 05:35:36 EDT 2012

Am 24.05.2012 21:55, schrieb Sascha Hauer:
> Hi Peter,
> On Wed, May 23, 2012 at 05:43:52PM +0200, Peter Kuennemann at Crane-Soft wrote:
>> Hi all.
>> I am trying to setup my PCM043/IMX35 board to boot from the
>> USB MMC card but til now I do have have any clue how to manage.
>> Searching the net, did not provide any hints regard that board.
>> I'ld like to have barebox to allow me to use the USB/MMC card
>> as boot device. Is there a chance to boot from SD-Card at all?
> Do you want to start barebox from USB/MMC or do you only want to load
> the kernel from USB/MMC? The latter is possible, though you have to add
> support for it. See arch/arm/boards/eukrea_cpuimx35/eukrea_cpuimx35.c
> for an example how to do it. Basically for MMC you have to configure
> the iomuxer and register the device. USB might be a bit more
> complicated, you have to configure the phy correctly.
> Sascba
Thanks a lot for your reply, Sascha. I'ld really want to load the
Kernel from the MMC and want to have the rootfs there as well. barebox
is goint to stay in flash anyhow.
I already tried to boot the Kernel from NOR/NAND but have problems to
mount the rootfs on MMC.
I think either way should work for us, booting kernel from MMC and having
rootfs on MMC or boot kernel from flash and have rootfs on MMC.
I'll investiage the sample that you referred to but I wonder if you could
point me into right direction regarding the rootfs on MMC?


To have kernel in flash and rootfs on MMC i tried bootargs as:

... root=/dev/mmcblk0p1 rootfstype=ext2 rootflags=noatime rw noinitrd rootwait ..

and it boots the kernel properly from flash up to:
mmcblk0: mmc0:a95c SD01G 968 MiB     <== Recognized the sd card
 mmcblk0: p1                         <== and partion 1
1f00             256 mtdblock0 (driver?)
1f01             128 mtdblock1 (driver?)
1f02            2048 mtdblock2 (driver?)
1f03           30336 mtdblock3 (driver?)
1f04         1048576 mtdblock4 (driver?)
b300          992000 mmcblk0 driver: mmcblk
  b301          991585 mmcblk0p1                    <=== Something missing here?
No filesystem could mount root, tried:  ext2        <===
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,1) <===

The mmc does contain a ext2 filesystem with the proper rootfs copied from
the jffs2.image that I mounted under Ubuntu as loop device. The kernel has ext2 fs
support compiled in.

The rootfs on the mmc is properly accessible when booting kernel and flash footfs
on the very same platform.


More information about the barebox mailing list