[PATCH 3/9] Samsung/serial: remove more ugly ifdef lines
Juergen Beisert
jbe at pengutronix.de
Fri Jul 20 15:29:39 EDT 2012
More or less just cosmetic. Easier to read, and lets the compiler remove unused
code.
Signed-off-by: Juergen Beisert <jbe at pengutronix.de>
---
drivers/serial/serial_s3c.c | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/serial/serial_s3c.c b/drivers/serial/serial_s3c.c
index 7a9b355..ff3792b 100644
--- a/drivers/serial/serial_s3c.c
+++ b/drivers/serial/serial_s3c.c
@@ -115,11 +115,10 @@ static int s3c_serial_init_port(struct console_device *cdev)
writeb(0xf, base + UINTM);
#endif
-#ifdef CONFIG_DRIVER_SERIAL_S3C_AUTOSYNC
- writeb(0x10, base + UMCON); /* enable auto flow control */
-#else
- writeb(0x01, base + UMCON); /* RTS up */
-#endif
+ if (IS_ENABLED(CONFIG_DRIVER_SERIAL_S3C_AUTOSYNC))
+ writeb(0x10, base + UMCON); /* enable auto flow control */
+ else
+ writeb(0x01, base + UMCON); /* RTS up */
return 0;
}
--
1.7.10.4
More information about the barebox
mailing list