[PATCH] ssb: workarounds: be verbose about hacking SPROM revision, don't duplicate code

Larry Finger Larry.Finger at lwfinger.net
Wed Nov 3 17:52:29 EDT 2010


On 11/03/2010 04:43 PM, Michael Büsch wrote:
> On Wed, 2010-11-03 at 22:06 +0100, Rafał Miłecki wrote: 
>> +	default:
>> +		ssb_printk(KERN_WARNING PFX "Unsupported SPROM"
>> +			   "  revision %d detected. Will extract"
>> +			   " v1\n", out->revision);
>> +		out->revision = 1;
>> +		sprom_extract_r123(out, in);
> 
> I think we should change this to throw a hard error if the sprom is
> unknown. Extracting r123 is unlikely to do any good these days.
> This workaround was only useful back in the days where 95% of the
> cards out there were r123. But today that's not the case.
> 
>> 	}
>>  
>>  	if (out->boardflags_lo == 0xFFFF)

In any case, the out->revision = 1 statement should be before the ssb_printk() call.

I agree - throw a hard error.

Larry



More information about the b43-dev mailing list