Kernel panic hosting 5Ghz AP

Konstantin Bogomolov konstantin.bogomolov at
Wed Nov 29 08:56:20 PST 2017

I've been trying to reproduce the issue on 4.14.1 for a few days now,
and it seems to have been stable so far (using ACS).

I should mention that I've been reproducing this using a torture test
where I first start a 2.4 Ghz AP, take it down, then start a 5 Ghz AP
(twice), then reboot and try again.

I am not sure whether starting the 2.4 Ghz AP before the other one
exacerbates the issue or not. Running the torture test on my 4.1
kernel (with 4.12 backports) worked for a while, until the kernel
crash happened, at which point starting the 5 Ghz AP led to a kernel
crash every time. On the stock Debian 4.9 kernel, it never worked and
crashed right away, until I tested it again after my 4.14.1 tests --
at which point it seemed to work.

So from what I've observed, the crash does not manifest itself right
away, but once it happens once, it continues happening without fail on
the subsequent tries. Having said that, 4.14.1 seems to be working
well considering its been ~5 days of running the torture test, whereas
4.1 (with 4.12 backports) crashed within 1-2 days.


On Mon, Nov 27, 2017 at 1:21 AM, Kalle Valo <kvalo at> wrote:
> Konstantin Bogomolov <konstantin.bogomolov at> writes:
>> Hello Kalle,
>> The panic happens after hostapd outputs "ACS-STARTED". Usually, the
>> first attempt for me to start hostapd fails to create the AP (I think
>> this is a separate issue with the 5Ghz AP), but the second attempt
>> always initiates a panic on Debian 4.9 drivers.
>> I don't think this is a regression, because I saw the same behaviour
>> on a custom 4.1 kernel. I have also tried using backported drivers
>> from 4.12.0 to both 4.1 and 4.9, where the panic was also reproducible
>> on the second hostapd attempt, but didn't happen every time as it does
>> on Debian 4.9. So the AP did work on some occasions using the
>> backports, but the panic still happened very frequently. Sadly I don't
>> have logs at this time using those backports.
>> I'll try and reproduce this using a recent kernel and let you know the results.
> Also try without ACS (meaning specify a channel mannually hostapd config
> file) just to see if the crash is ACS related.
> --
> Kalle Valo

More information about the ath10k mailing list