[PATCH v6 06/10] ath10k: add sdio extra initializations
Kalle Valo
kvalo at qca.qualcomm.com
Thu Mar 23 08:59:53 PDT 2017
Ryan Hsu <ryanhsu at qca.qualcomm.com> writes:
> On 03/15/2017 08:46 AM, Kalle Valo wrote:
>
>> From: Erik Stromdahl <erik.stromdahl at gmail.com>
>>
>> Extra initializations needed by all sdio boards.
>> Derived from qcacld.
>>
>> Signed-off-by: Erik Stromdahl <erik.stromdahl at gmail.com>
>> Signed-off-by: Kalle Valo <kvalo at qca.qualcomm.com>
>> ---
>> drivers/net/wireless/ath/ath10k/core.c | 22 ++++++++++++++++++++--
>> 1 file changed, 20 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/wireless/ath/ath10k/core.c b/drivers/net/wireless/ath/ath10k/core.c
>> index f450ebbb28d5..6b6ea8a571fa 100644
>> --- a/drivers/net/wireless/ath/ath10k/core.c
>> +++ b/drivers/net/wireless/ath/ath10k/core.c
>> @@ -377,7 +377,22 @@ static void ath10k_send_suspend_complete(struct ath10k *ar)
>> complete(&ar->target_suspend);
>> }
>>
>> -static int ath10k_init_configure_target(struct ath10k *ar)
>> +static void ath10k_sdio_extra_initialization(struct ath10k *ar)
>> +{
>> + u32 param = 0;
>> +
>> + ath10k_bmi_write32(ar, hi_mbox_io_block_sz, 256);
>> + ath10k_bmi_write32(ar, hi_mbox_isr_yield_limit, 99);
>> + ath10k_bmi_read32(ar, hi_acs_flags, ¶m);
>> +
>> + param |= (HI_ACS_FLAGS_SDIO_SWAP_MAILBOX_SET |
>> + HI_ACS_FLAGS_SDIO_REDUCE_TX_COMPL_SET |
>> + HI_ACS_FLAGS_ALT_DATA_CREDIT_SIZE);
>> +
>> + ath10k_bmi_write32(ar, hi_acs_flags, param);
>> +}
>> +
>> +static int ath10k_init_sdio(struct ath10k *ar)
>
> Shouldn't we just keep the ath10k_init_configure_target() and move the
> sdio specific to ath10k_sdio_extra_initialization()?
> instead of renaming this to ath10k_init_sdio()? not sure if this is
> just a local hack that didn't revert?
Ouch, I was supposed to rename ath10k_sdio_extra_initialization() to
ath10k_init_sdio() but accidentally renamed the wrong function. Will fix
in v7.
Thanks for catching this!
--
Kalle Valo
More information about the ath10k
mailing list