Anyone brought up 9984 NIC on x86-64?

Ben Greear greearb at
Wed Jul 13 14:14:54 PDT 2016

On 07/13/2016 10:54 AM, Ben Greear wrote:
> On 07/13/2016 10:26 AM, Manoharan, Rajkumar wrote:
>>> I added a few patches to my 4.7 kernel to enable ath10k to load for 9984,
>>> but it immediately crashes due to IOMMU error when trying to allocate
>>> memory.
>>> I'm building the latest linux-ath tree now and will test that when it
>>> is done, but I am curious to know if anyone has successfully booted
>>> 9984 on x86-64?
>> Ben,
>> Are you seeing IOMMU error even after wtih your DMA_BIDIRECTIONAL change? Could you please try with
> My BIDIRECTIONAL patch is in my 4.7, and that did not fix the issue.
> It is more for the IOMMU access failures that I saw and the redhat user reported.
> I would appreciate it if you could roll that patch into your testing set and
> make sure you don't see regressions on your systems.  That way maybe it can go
> upstream.
> For reference, this is today's un-patched linux-ath:
> DMA: Out of SW-IOMMU space for 770224 bytes at device 0000:05:00.0
> Kernel panic - not syncing: DMA: Random memory could be DMA read
> CPU: 5 PID: 288 Comm: kworker/u16:3 Not tainted 4.7.0-rc7-wt-ath+ #34
> Hardware name: To be filled by O.E.M. To be filled by O.E.M./ChiefRiver, BIOS 4.6.5 06/07/2013
> Workqueue: ath10k_aux_wq ath10k_wmi_event_service_ready_work [ath10k_core]
>   0000000000000000 ffff8800d3edfbf0 ffffffff8140abd1 ffffffff81c88b78
>   ffff8800d3edfc80 ffff8800d3edfc70 ffffffff811ea260 ffff880000000008
>   ffff8800d3edfc80 ffff8800d3edfc18 ffffffff811ea591 ffff88021e34db68
> Call Trace:
>   [<ffffffff8140abd1>] dump_stack+0x63/0x82
>   [<ffffffff811ea260>] panic+0xca/0x216
>   [<ffffffff811ea591>] ? printk+0x43/0x4b
>   [<ffffffff814382a2>] swiotlb_map_page+0x1a2/0x1d0
>   [<ffffffffa07ea1a9>] ath10k_wmi_event_service_ready_work+0x3f9/0x750 [ath10k_core]
>   [<ffffffff8113667a>] ? dequeue_entity+0x26a/0xba0
>   [<ffffffff8111aebd>] process_one_work+0x15d/0x4b0
>   [<ffffffff8111b253>] worker_thread+0x43/0x4e0
>   [<ffffffff8111b210>] ? process_one_work+0x4b0/0x4b0
>   [<ffffffff81120a34>] kthread+0xc4/0xe0
>   [<ffffffff81853e9f>] ret_from_fork+0x1f/0x40
>   [<ffffffff81120970>] ? kthread_worker_fn+0x180/0x180
> Kernel Offset: disabled
> ---[ end Kernel panic - not syncing: DMA: Random memory could be DMA read
> I tried with your patch set to 512 block size, but that fails with
> similar DMA error and reboots.
> Your original patch with 256 block size boots up the firmware OK on my
> system.
> I guess I'll do more testing with your original 256k chunk patch and see
> how that works.

I just realized that I was booting with "intel_iommu=off", that is probably why
I had to enable the 256k chunk patch.

And FYI, at least my 9984 firmware appears to blow up when passed multiple
chunks...I'm still trying to figure out exactly why.

That said, would be nice if ath10k worked on systems w/out intel-iommu too...


Ben Greear <greearb at>
Candela Technologies Inc

More information about the ath10k mailing list