R: Link can't get estabilished over RB911AC boards

Alessandro Bolletta alessandro at mediaspot.net
Tue Sep 22 14:26:13 PDT 2015

Hi Marcel,
have you ported CT kernel commits in OpenWRT buildroot, or are you running it in a full blown distro?

Alessandro Bolletta
Mediaspot Srl

Da: Marcel H. [mailto:maco at blava.net] 
Inviato: martedì 22 settembre 2015 22.48
A: Alessandro Bolletta <alessandro at mediaspot.net>
Cc: ath10k at lists.infradead.org
Oggetto: Re: Link can't get estabilished over RB911AC boards

Had the very same problem with my install. Ct's 4.0 kernel with their community 15 beta firmware sorted the issue. 

On Monday, 21 September 2015, Alessandro Bolletta <alessandro at mediaspot.net> wrote:

I have two Mikrotik RB911AC boards (radio based on QCA9882) in which I injected OpenWRT 15.05 and ath10k.

I managed to get them connected in AP/STA configuration in a very short (2 meters) distance, but when I try to connect them on 5 kilometers, even if I set the distance parameter on OpenWRT's UCI config files properly, it tries to connect but after 3 retries, it declares unauthenticated.

No problem with the same firmware on ath9k, for example.
Signal is stable at -62 dbm, I also tried to change channels and push tx power, but nothing helped to do the trick.
Also tried with every firmware combination (10.2.4, CT firmware, 999.999.0.636, 10.1.467.2-1), without success.

Is there anybody who can tell me why? Could it be due to the kernel version (i'm running on 3.18.21)?

Thanks in advance,

Alessandro Bolletta
Mediaspot Srl

ath10k mailing list
ath10k at lists.infradead.org


This message is not intended to have
contractual effect

More information about the ath10k mailing list