QCA6174 hw2.1 Firmware crash when connecting to a 5GHz network

Roman Bange mofasofa123 at gmx.de
Wed Nov 25 04:12:03 PST 2015

Sorry for my late answer.
Sadly the AP's im connecting to, are part of my universities wifi so i can't tell you the excat chipset they use.
I tried to connect without the network manager so i followed the instructions and did a try with wpa_supplicant.

I attached you the log i got, but sadly it didn't work either.

Btw... connecting to a unencrypted 5Ghz network works fine. But when i try to build up a connection with an VPN over an unencrypted wifi fails too.


Gesendet: Donnerstag, 19. November 2015 um 11:09 Uhr
Von: "Bartosz Markowski" <bartosz.markowski at tieto.com>
An: "Roman Bange" <mofasofa123 at gmx.de>
Cc: ath10k <ath10k at lists.infradead.org>
Betreff: Re: QCA6174 hw2.1 Firmware crash when connecting to a 5GHz network
On 18 November 2015 at 16:28, Roman Bange <mofasofa123 at gmx.de> wrote:
> Hey,
> im getting a firmware crash when i try to connect to a 5GHz network.
> I tested the older firmware WLAN.RM.1.1-00141, which is now provided in linux-firmware, and SW_RM.1.1.1-00157-QCARMSWPZ-1, which is provided by you in ath10k-firmware.
> SW_RM.1.1.1-00157-QCARMSWPZ-1 didn't crash but i wasn't able to connect either.
> In addition i tested a solution that worked for me with the 4.1 Kernel where i extracted the firmware out of the windows driver (and can be found here (https://github.com/sumdog/ath10k-firmware). This solution didn't worked for me too.
> I tested the firmware with 4.2.0-16 under Ubuntu, but experienced the same problem with the stable releases 4.2.6 and 4.3 too. I have not tested the 4.4-rc1 Kernel yet because its not compilable with the Ubuntu packages.

The firmware crash you experience with "older" firmwares got fixed in
the 000157.
It's most likely related with wrong txbf capability advertisement,
which your card (and firmware for it) does not support.

May I ask what AP you test with?

> I attached the related dmesg logs to this mail.

When you use the 000157 firmware you can see there's a successful
auth/assoc seq. but later on for some reason there's a local deauth

[ 58.966382] wlp3s0: authenticate with f0:7f:06:2a:44:2d
[ 59.008957] wlp3s0: send auth to f0:7f:06:2a:44:2d (try 1/3)
[ 59.009546] wlp3s0: authenticated
[ 59.014268] wlp3s0: associate with f0:7f:06:2a:44:2d (try 1/3)
[ 59.019139] wlp3s0: RX AssocResp from f0:7f:06:2a:44:2d (capab=0x11
status=0 aid=6)
[ 59.022291] wlp3s0: associated
[ 59.022324] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[ 62.130412] wlp3s0: deauthenticating from f0:7f:06:2a:44:2d by
local choice (Reason: 3=DEAUTH_LEAVING)

And these steps repeat in your log.

Could you try to connect with the AP w/o the network manager (using
wpa_supplicant / wpa_cli directly)?

> Best regards,
> Roman
> _______________________________________________
> ath10k mailing list
> ath10k at lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/ath10k[http://lists.infradead.org/mailman/listinfo/ath10k]

-------------- next part --------------
A non-text attachment was scrubbed...
Name: wpasupplicant log
Type: application/octet-stream
Size: 43405 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/ath10k/attachments/20151125/8f4e1b0f/attachment-0001.obj>

More information about the ath10k mailing list