[PATCH 0/8] ath10k: clean up ath10k_skb_cb
Michal Kazior
michal.kazior at tieto.com
Mon Nov 2 06:03:00 PST 2015
The ath10k_skb_cb structure wasn't really space
efficient. Some stuff is removed or replaced with
more compact representation.
This cleanup is necessary for future features.
The size of ath10k_skb_cb:
before after
x86-32 26 12
x86-64 34 20
Michal Kazior (8):
ath10k: merge is_protected with nohwcrypt
ath10k: rename function to adhere to naming convention
ath10k: remove txmode from skb_cb
ath10k: remove is_offchan
ath10k: remove freq from skb_cb
ath10k: pack up flags in skb_cb
ath10k: replace vdev_id and tid in skb cb
ath10k: store msdu_id instead of txbuf pointers
drivers/net/wireless/ath/ath10k/core.h | 27 +++----
drivers/net/wireless/ath/ath10k/htt.h | 3 +-
drivers/net/wireless/ath/ath10k/htt_tx.c | 111 ++++++++++++++++++-----------
drivers/net/wireless/ath/ath10k/mac.c | 116 +++++++++++++++----------------
drivers/net/wireless/ath/ath10k/mac.h | 1 +
drivers/net/wireless/ath/ath10k/txrx.c | 7 +-
drivers/net/wireless/ath/ath10k/wmi.c | 22 ++++--
7 files changed, 165 insertions(+), 122 deletions(-)
--
2.1.4
More information about the ath10k
mailing list