AP mode firmware crash on QCA9880-BR4A

Michal Kazior michal.kazior at tieto.com
Sun Aug 16 22:46:06 PDT 2015

On 8 August 2015 at 23:06, Martin Blumenstingl
<martin.blumenstingl at googlemail.com> wrote:
> Hi Michal,


Sorry for my late reply.

> On Tue, Aug 4, 2015 at 7:19 AM, Michal Kazior <michal.kazior at tieto.com> wrote:
>> It could be that your devices are not transmitting Probe Requests and
>> scan passively 5GHz channels due to their regulatory restrictions. Can
>> you try getting traces to confirm this, please?
> I have just tried it again and today I *can* see the AP on one of my
> Android devices (I haven't tried the second one, but that should also
> see it).
> During my testing I found out that ath10k_wmi_beacon_send_ref_nowait()
> is the command that makes it crash.
> I re-enabled everything in ath10k_wmi_event_host_swba() and it started
> crashing again.
> A few tests later I found that removing the following line "fixes" the
> crashes (but it will obviously break other things!):
>     arvif->beacon_state = ATH10K_BEACON_SCHEDULED;
> Thus I came to the conclusion that I should try disabling
> "pdev_send_bcn_cmdid" to the device.

Hardly a solution, obviously.

> I made two traces (with firmware, you can find them both
> in this tarball: [0]
> trace. was recorded without any ath10k patches
> trace. was recorded with
> ath10k_wmi_beacon_send_ref_nowait that has ath10k_wmi_cmd_send_nowait
> removed (see [1])

I'm out of ideas for now. Apparently the device can Tx as it can send
out Probe Responses but for some reason it doesn't like beaconing..


More information about the ath10k mailing list