[Pcsclite-muscle] (hardware?) problem using "lindy" reader

Ludovic Rousseau ludovic.rousseau
Tue Oct 20 09:06:55 PDT 2015

2015-10-20 16:27 GMT+02:00 Thomas Capricelli <orzel at freehackers.org>:

> Hello,


> (technical details at bottom)
> I just bought a reader on amazon. Some people in comments reported that it
> was working on ubuntu, and it's supposed to be CCID compliant, so I was
> pretty optimistic.
> Unfortunately, i haven't been able to do much yet. I'm suspecting a
> hardware problem, but I wanted to be sure, so here's a full report.
> The problem is the following : the card is found by pcsc_scan, but when i
> insert a card, it always report:
> Reader 0: Generic Smart Card Reader Interface [Smart Card Reader
> Interface] (20070818000000000) 00 00
>   Card state: Card inserted, Unresponsive card,
> I've tried:
>     * two different bank cards
>     * transportation card (French Navigo)
>     * (French) driving license card
>     * Health card (French Carte Vitale)
> (yes, I'm French
> And I got the same answer for each.
> Then I've tried a SIM Card, and quite surprisingly, it works well, totally
> reproducible:
> Reader 0: Generic Smart Card Reader Interface [Smart Card Reader
> Interface] (20070818000000000) 00 00
>   Card state: Card inserted,
>   ATR: 3B 16 94 71 01 01 06 02 00
>   ....
> So now i'm confused. I would say that most of the stack is working (usb,
> ccid driver, pcsc), and it even confirms i know how to put the card in (ths
> is not obvious, the connection pins could be either up or down).
> So either something is broken in hardware, or I'm missing some nifty
> configuration stuff for the driver.

I would suspect a very limited hardware/firmware.

> I'm suspecting something related to voltage, so I've tried to change
> Info.plist as described in /usr/share/doc/ccid-1.4.15/README.bz2,
> unfortunately I've had no success so far. Actually, I'm not even sure my
> changes are taken into account. The documentation says that I need to
> unplug the (only one) driver i have and replug it, but I haven't seen any
> visual confirmation that something was reloaded.
> This file Info.plist has weird documentation. parameters are in hexa, like
> <string>0x0009</string>, but comments mention decimal numbers such as 16,
> 32 (so that they probably really are decimals).

Now fixed. Thanks.

> The only Windows OS I got is Windows 7 in a virtualbox. I tried this (you
> can route a physical usb device to the virtual machine). Windows installs
> some driver (CCID i guess) and then using python/pyscard i have the same
> kind of error (card present, but not answering)
> pcscd mentions to report but to "lists.musclecard.com", but this name
> doesn't resolve.

Now fixed. Thanks.

> That's where I am. Any hint about what's happening or what I could try
> next ?

Buy another model of reader.
Choose a reader from the "supported" list

> I'm available on irc/freenode as 'orzel' if needed.
> best regards,
> --
> Thomas Capricelli <orzel at freehackers.org>
> http://www.freehackers.org/thomas/
> Technical information / detailed "bug report"
> Versions:
> ccid-1.4.20 (I tried ccid-1.4.15 as well)
> pcsc-lite-1.8.14 (I tried pcsc-lite-1.8.12 too)
> My reader is called "Lindy 42768", which is based on the Realtek stuff
> that seems pretty common
> in this kind of reader :
>     http://www.amazon.fr/gp/product/B003SW1IL2

>From one customer comment on Amazon I read:
" Il est possible de lire des cartes ? puces, mais pour celui qui veut lire
sa carte Vitale, bancaire ou autres, il faut s'abstenir, ce n'est pas ce
produit qu'il lui faut. "

The best I can do is moved the reader from the "Should work but untested by
me" list to the "Unsupported or partly supported CCID readers" list.


 Dr. Ludovic Rousseau
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pcsclite-muscle/attachments/20151020/dfbe9ffe/attachment-0001.html>

More information about the pcsclite-muscle mailing list