[PATCH 00/11] Improve the common MPXY RPMI driver

Anup Patel anup at brainfault.org
Sun Oct 25 02:06:36 PDT 2026


On Wed, Sep 23, 2026 at 8:54 AM Anup Patel <anup.patel at oss.qualcomm.com> wrote:
>
> Currently, the commont MPXY RPMI driver is only focused on emulating
> MPXY channel on-top-of hardware RPMI service group channel. In real
> world, we will also have MPXY RPMI channels between domains as well
> as pure software emulated MPXY RPMI channels. To address this, improve
> the common MPXY RPMI driver to support inter-domain and software
> emulated channels.
>
> These patches can also be found in mpxy_rpmi_imp_v1 branch at:
> https://github.com/avpatel/opensbi.git
>
> Anup Patel (10):
>   lib: utils/mpxy: Rename fdt_mpxy_rpmi_mbox to fdt_mpxy_rpmi
>   lib: utils/mpxy: Setup group early in fdt_mpxy_rpmi_init()
>   lib: utils/mpxy: Introduce get_attribute_group() for MPXY RPMI data
>   lib: sbi_domain: Introduce sbi_domain_find_by_name() function
>   lib: utils/mpxy: Introduce mpxy_rpmi_no_mbox_init() function
>   lib: utils/mpxy: Simplify fdt_mpxy_rpmi.h by moving things to
>     fdt_mpxy_rpmi.c
>   lib: sbi_domain: Make domain regions as fixed array
>   lib: sbi_domain: Allow adding memrange to a particular domain from
>     drivers
>   lib: utils/mpxy: Add domain parameter to setup_group() callback
>   lib: utils/mpxy: Use domain notifier for deferred creation of MPXY
>     RPMI
>
> Oza Pawandeep (1):
>   lib: sbi_domain: Add domain notifier infrastructure
>
>  include/sbi/sbi_domain.h                    |  73 ++-
>  include/sbi_utils/mpxy/fdt_mpxy_rpmi.h      |  58 +++
>  include/sbi_utils/mpxy/fdt_mpxy_rpmi_mbox.h |  85 ---
>  lib/sbi/sbi_domain.c                        | 172 +++++--
>  lib/utils/fdt/fdt_domain.c                  |  17 +-
>  lib/utils/mpxy/Kconfig                      |   6 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi.c              | 540 ++++++++++++++++++++
>  lib/utils/mpxy/fdt_mpxy_rpmi_clock.c        |   7 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_device_power.c |   7 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_logging.c      |   7 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_mbox.c         | 362 -------------
>  lib/utils/mpxy/fdt_mpxy_rpmi_mm.c           |  15 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_performance.c  |   7 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_sysmsi.c       |  10 +-
>  lib/utils/mpxy/fdt_mpxy_rpmi_voltage.c      |   7 +-
>  lib/utils/mpxy/objects.mk                   |   2 +-
>  platform/generic/configs/defconfig          |   2 +-
>  platform/generic/mips/eyeq7h.c              |   6 +-
>  18 files changed, 838 insertions(+), 545 deletions(-)
>  create mode 100644 include/sbi_utils/mpxy/fdt_mpxy_rpmi.h
>  delete mode 100644 include/sbi_utils/mpxy/fdt_mpxy_rpmi_mbox.h
>  create mode 100644 lib/utils/mpxy/fdt_mpxy_rpmi.c
>  delete mode 100644 lib/utils/mpxy/fdt_mpxy_rpmi_mbox.c
>
> --
> 2.43.0
>

Applied this series to the riscv/opensbi repo.

Thanks,
Anup



More information about the opensbi mailing list