Error in the push function.

Mitchell Dorrell mwd at
Thu Nov 18 19:24:38 PST 2021

Hello Dan,

I can offer a bit of context. I had possession of this laptop
originally, running Ubuntu 18.04. I initially configured the VPN
connection a few years ago, and it worked successfully on a day-to-day
basis up until I last tested it a few weeks ago. (I have forgotten any
headaches that may have been involved in the initial setup.) It should
be the current version in the Ubuntu 18.04 repos, so... openconnect

In case it's relevant, the VPN connection requires a smart card with a
PIN for authentication.

Upon leaving the organization, I transferred the laptop to Amirali
(created a new user, deleted my old one), and unfortunately the VPN
connection didn't "just work" for him. We tried bypassing the GUI by
running openconnect from the command line, which resulted in the
output Amirali has shown previously. I'm confident I've never seen the
"Error in the push function" message before, so I suggested Amirali
reach out to the OpenConnect community for assistance.

I hope this additional context helps!
Mitchell Dorrell

On Thu, Nov 18, 2021 at 8:25 PM Daniel Lenski <dlenski at> wrote:
> On Thu, Nov 18, 2021 at 1:33 PM Amirali Hossein <amirali.h71 at> wrote:
> > How should I resolve "Error in the push function."?
> Can you give us more information? Start with the complete output of
> `openconnect --version`, and what operating system you're running on.
> All I can tell from the messages ("SSL connection failure" and "Failed
> to obtain WebVPN cookie") is that you're using a GnuTLS-based build,
> and it must be older than
> > VPN Log:
> What is this "VPN Log"? How was it generated? It doesn't appear to
> contain any useful information at all.
> Dan
> _______________________________________________
> openconnect-devel mailing list
> openconnect-devel at

More information about the openconnect-devel mailing list