SSL read error: Success when DTLS is on

Nikos Mavrogiannopoulos n.mavrogiannopoulos at
Wed Mar 29 01:28:46 PDT 2017

On Wed, Mar 29, 2017 at 4:03 AM, Siyuan Ren <netheril96 at> wrote:
> Recently the openconnect client on my machine stops working with DTLS
> on. It constantly displays "SSL read error: Success.; reconnecting."
> which is rather confusing.
> My machine is a MacBook Pro (Retina, 15-inch, Late 2013) with macOS
> Sierra 10.12.4 (16E195). `openconnect` is installed by `homebrew` at
> /usr/local with default options. Both bottle and build-from-source
> have been tried. The server is run by ocserv 0.11.7 on Debian jessie.
> Connecting without DTLS or with Cisco Anyconnect iOS client work fine.
> Connecting via IPv4 or IPv6 show the same error on macOS, and the same
> success with Cisco Anyconnect.
> Following is the full log output when connecting to my server until I
> interrupted it since it was constantly reconnecting.

You have to see what is going on, on the server or any relevant middle
box. Although the error message is confusing, Success here means that
the client received the value 0 on the SSL channel, meaning that the
peer has closed the connection.


More information about the openconnect-devel mailing list